Networking Reference
In-Depth Information
This is quite an intricate question because you are permitted to use only a single ACL to filter the routes on R3. The
method in which you achieve this is to use an ACL that matches networks up to 128.0.0.0 and permits this through one
route-map while denying through a separate route-map. The route-maps should be applied on a per-neighbor basis, and
both call up the same single ACL. Example 1-27 shows the configuration for the new Loopbacks on R1 and R2 and the
filtering on R3. Further testing is detailed in Example 1-28 to substantiate the filtering process on R3. If you have con-
figured this correctly, as shown in Example 1-27, you have scored 3 points.
EXAMPLE 1-27
Route-Map Filtering on R3
R1(config)# interface Loopback1
R1(config-if)# ip address 126.1.1.1 255.255.255.0
R1(config-if)# router bgp 10
R1(config-router)# network 126.1.1.0 mask 255.255.255.0
R2(config)# interface Loopback1
R2(config-if)# ip address 130.1.1.1 255.255.255.0
R2(config-if)# router bgp 10
R2(config-router)# network 130.1.1.0 mask 255.255.255.0
R3(config)# access-list 1 permit 0.0.0.0 127.255.255.255
R3(config)# route-map UPTO128 permit 10
R3(config-route-map)# match ip add 1
R3(config)# route-map ABOVE128 permit 10
R3(config-route-map)# match ip add 1
R3(config-route-map)# route-map ABOVE128 permit 20
R3(config)# router bgp 10
R3(config-router)# neighbor 120.100.1.1 route-map UPTO128 in
R3(config-router)# neighbor 120.100.2.1 route-map ABOVE128 in
R3# sh ip bgp
BGP table version is 8, local router ID is 120.100.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Search MirCeyron ::




Custom Search